Skip to main content

Configuration MikroTik

Login par défaut: admin sans mot de passe.

Commandes principales

Navigation

Nom de la commande dans l’arborescence

Description

[admin@MikroTik] ip address>..

[admin@MikroTik] ip>

La commande « .. » permet de revenir au niveau inférieur.

[admin@MikroTik] ip address> /

[admin@MikroTik] >

La commande « / » permet de revenir à la racine peu importe le niveau où le prompt se trouve.

Gestion de la configuration

Nom de la commande dans l’arborescence

Description

/system backup save name=test

Sauvegarder la configuration sous le nom test

/system backup load name=test

Restaurer la configuration au redémarrage du matériel.

/system reset-configuration

Effectue un hard reset du matériel (toutes les configurations seront perdu.)

/system reboot

Redémarrer le matériel

Commandes de visualisation

Nom de la commande dans l’arborescence

Description

/file print

Afficher les fichiers stockés sur le matériel

/ip address print

Afficher les adresses IP affectées aux différentes interfaces

/ip route print

Afficher la table de routage sur un routeur

/interface print

Afficher les différentes interfaces présentes (Physiques / virtuelles)

/ip arp print

Afficher la table arp

/interface ethernet print detail

Afficher les détails d’une interface.

/interface wireless info country-info etsi

Affiche les fréquences autorisées du pays "etsi"

/interface ethernet monitor ether1,ether2

Permet le monitoring d’interfaces (Détection des liens / vitesse etc...)

/system console print

Afficher les différentes consoles

/system package print

Afficher les différents packages

/ping 192.168.1.1

Effectue un ping vers la destination spécifiée.

/ping 8.8.8.8 src-address=192.168.10.254

Permet d’émuler un ping provenant d’une adresse source (sur le réseau local par exemple) vers une adresse de destination (sur Internet)

Commandes de modification

Nom de la commande dans l’arborescence

Description

/system package uninstall security

/system package enable ipv6

/system reboot

Exemple de gestion des package : désinstallation du package “Security”,

Installation du package “ipv6”,

redémarrage du matériel pour prendre en compte les modifications.

/interface enable ether1

Activer l’interface ether1

/ip address add address=10.10.10.1/24 interface=ether2

1ère commande : affecter l’adresse 10.10.10.1 et le masque 255.255.255.0 à l’interface nommée “ether2”

/ip route add dst-address=10.1.12.0/24 gateway=192.168.0.253

Ajouter une route statique vers un réseau (illustration avec le réseau 10.1.12.0/24)

/ip route add gateway=10.5.8.1

Ajouter une passerelle (10.5.8.1) pour la route par défaut (0.0.0.0)

VLAN

Nom de la commande dans l’arborescence

Description

/interface vlan add name=test vlan-id=1 interface=ether1

Ajouter le VLAN 1 nommé test sur l’interface ether 1

/interface vlan print

Afficher les différents VLAN

/ip address add address=10.10.10.1/24 interface=test

Ajouter une adresse IP à une interface virtuelle de VLAN (sous-interface par rapport à l’interface physique.

Ne pas oublier de créer une interface vlan aussi sur wlan1 ainsi qu'un bridge pour faire transiter le traffic de vlan test entre les interfaces.

Services

DHCP

Etape

Nom de la commande dans l’arborescence

Description

1

/ip pool add name=dhcp-pool ranges=192.168.1.1-192.168.1.100

Créer une plage d’adresses distribuée par le serveur DHCP : de 192.168.1.1 à 192.168.1.100

2

/ip dhcp-server network add address=192.168.1.0/24 gateway=192.168.1.254 \ dns-server=159.148.147.194,159.148.60.20

Ajouter la passerelle par défaut et les adresse vers les DNS primaire et secondaires sur dans la plage DHCP configurée précédemment.

3

/ip dhcp-server add interface=wlan1 address-pool=dhcp-pool

Spécification de l’interface sur laquelle le serveur DHCP doit travailler et de la plage d’adresses IP distribuée.

/ip dhcp-server lease print

Afficher les adresses IP attribuées par le serveur DHCP.

Monitoring (Graphiques)

Nom de la commande dans l’arborescence

Description

/tool graphing interface add interface=ether1

Cette commande active les graphiques pour l’interface ether1

/tool graphing resource add allow-address=192.168.0.0/24

Cette option affichera le graphique uniquement pour le réseau 192.168.0.0/24

Mises à jour & Mises à niveau

Nom de la commande dans l’arborescence

Description

/system package update check-for-updates Vérifie les mises à jour de paquets
/system package update install Installe les mises à jour de paquets et redémarre automatiquement à la fin
/system routerboard print Affiche si un mise à jour est disponible pour le firmware de la carte-mère

/system routerboard upgrade

Effectue la mise à niveau du firmware de la carte-mère

/interface lte firmware-upgrade lte1

Affiche si un mise à jour est disponible pour le firmware de la carte LTE

/interface lte firmware-upgrade lte1 upgrade=yes

Effectue la mise à niveau du firmware de la carte LTE

/system routerboard settings set boot-device=try-ethernet-once-then-nand

Passe le routeur en netboot au prochain redémarrage

Service WinBox

Nom de la commande dans l’arborescence

Description

/tool mac-server mac-winbox disable numbers=0 Désactive les connexions MAC pour WinBox
/tool mac-server set [find] disabled=yes
/tool mac-server mac-winbox set [find] disabled=yes
/tool mac-server ping set enabled=no
Désactive WinBox via MAC
/ip service disable winbox Désactive complètement WinBox

/ip firewall filter add action=drop chain=input comment="DROP ALL WINBOX REQUEST EXCEPT FROM AUTORIZED IP" disabled=no dst-port=8291 protocol=tcp src-address=!10.255.0.0/24

Désactive l'accès WinBox aux IP autres que le sous-réseau 10.255.0.0/24

/ip neighbor discovery set ether1 discover=no

Désactive la découverte de voisins

/tool romon set enabled=no Désactive RoMON

Bonus

L'administration est aussi possible via les logiciels The Dude et Winbox

Création NAT
/ip address add address=192.168.13.31/24 interface=ether1 network=192.168.13.0
/ip pool add name=pool13 ranges=192.168.13.120-192.168.13.150
/ip dhcp-server add address-pool=pool13 disabled=no interface=ether1 name=server1
/ip dhcp-client add disabled=no interface=ether2
/ip dhcp-server network add address=192.168.13.0/24 dns-server=192.168.13.31 gateway=192.168.13.31
/ip dns set allow-remote-requests=yes
/ip firewall nat add action=masquerade chain=srcnat out-interface=ether2 src-address=192.168.13.0/24
Forwarder un port
/interface list add name=WAN
/interface list member add interface=ether1 list=WAN
/ip firewall nat add action=dst-nat chain=dstnat disabled=yes dst-port=22 in-interface-list=WAN protocol=tcp to-addresses=192.168.13.2 to-ports=22
unicast key exchange timeout / 4-way handshake timeout

problème de 2009 toujours pas résolu par mikrotik: https://forum.mikrotik.com/viewtopic.php?p=431229#p150433

ce problème apparaît quand une antenne avec un profil de sécurité autre que default se connecte avec une antenne utilisant le profil default.
solution: faire utiliser le même profil aux 2, que ce soit le profil par défaut ou un autre créé.